CyberSEO Pro is WPML compatible now

  Just want to remind you that CyberSEO Pro ver. 7.104 and higher is officially compatible with WPML – the WordPress Multilingual Plugin, which lets you fully optimize your site for SEO in multiple languages. WPML makes it easy to run a multilingual website with a single WordPress installation. Choose languages for your site and Read more about CyberSEO Pro is WPML compatible now[…]