May 4, 2011

Error using ESpinner | CyberSEO Pro | Support Forums

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_topicicon
Error using ESpinner
Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 (0 votes) 
November 4, 2020
8:44 pm
Avatar
Member
Members
Forum Posts: 4
Member Since:
October 23, 2020
sp_userofflinesmall Offline

Hi!

I have configured the API and email info about using Espinner in the ESpinner tab and

But when using ESpinner to spin a post, Wordpress crash, and this is the report:

Error Details
=============
An error of type E_ERROR was caused in line 3 of the file /home/XXXX/XXXXX/wp-content/plugins/cyberseo/cyberseo.php(52) : eval()’d code. Error message: Uncaught Error: Using $this when not in object context in /home/XXXXXX/XXXXX/wp-content/plugins/cyberseo/cyberseo.php(52) : eval()’d code:3
Stack trace:
#0 /home/XXXXX/XXXXX/wp-content/plugins/cyberseo/cyberseo.php(52) : eval()’d code(3): cseo_espinner(‘ Docentes y per…’)
#1 /home/XXXXX/XXXXX/wp-content/plugins/cyberseo/cyberseo.php(52) : eval()’d code(3): cseo_morph_content(‘ Docentes y per…’)
#2 /home/XXXXX/XXXXX/wp-content/plugins/cyberseo/cyberseo.php(52) : eval()’d code(3): CyberSEO_Syndicator->insertPost()
#3 [internal function]: CyberSEO_Syndicator->endElement(Resource id #370, ‘ITEM’)
#4 /home/XXXXX/XXXXX/wp-content/plugins/cyberseo/cyberseo.php(52) : eval()’d code(3): xml_parse(Resource id #370, ‘\t\t\t\t\t\t\t\t\t\tparseFeed(‘https://efectoc…’)
#6 /home/XXXXX/XXXXXt/wp-content/plugin

Can you help me to identify the problem?

Thanks!

November 4, 2020
9:44 pm
Avatar
Admin
Forum Posts: 3134
Member Since:
July 2, 2009
sp_userofflinesmall Offline

I need to reproduce this error at my test site. To do so I need your ESpinner email/API key along with the instruction on what I should to do to get the same error message. Please send it to my email.

November 6, 2020
12:00 am
Avatar
Member
Members
Forum Posts: 4
Member Since:
October 23, 2020
sp_userofflinesmall Offline

Thanks! I will send you this information to your email.

November 6, 2020
1:48 pm
Avatar
Admin
Forum Posts: 3134
Member Since:
July 2, 2009
sp_userofflinesmall Offline

Fixed in version 8.021. Make sure to manually update your plugin. Go to CyberSEO Pro -> General Settings and click at “Update the plugin to the latest version“.

November 10, 2020
12:53 pm
Avatar
Member
Members
Forum Posts: 4
Member Since:
October 23, 2020
sp_userofflinesmall Offline

Thank you!
I have updated the plugin and now it no longer gives that error.
However, although it seems to work correctly, the published text is not “spinned”, it is the same as the original.

Checking in the ESpinner user panel, I do see that words have been consumed and a “spin” has been executed but the article finally published by Cyberseo is the same as the original.

Do you know where the problem could be?

Here is the Cyberseo log:

[11-10-20 09:11:14] Syndicating from Login to see this link.
[11-10-20 09:11:14] Processing post “Biden would make XXXXXX”.
[11-10-20 09:11:14] Trying to extract text article.
[11-10-20 09:11:15] Trying to spin content with ESpinner …
[11-10-20 09:11:17] The featured image has been successfully generated.
[11-10-20 09:11:17] 1 post was added.

The post was added correctly, but with the same content as the original.

Thanks!

November 10, 2020
2:19 pm
Avatar
Admin
Forum Posts: 3134
Member Since:
July 2, 2009
sp_userofflinesmall Offline

I made some changes, thus please update the plugin one more time. However, you should not see a serious difference, because ESpinner changes just a few words in the original article… You may enable the “Text with Spintax” mode in the CyberSEO Pro ESpinner settings to see which exactly words it t(the spinner) tries to replace. Those will be shown like {an original word|a synonym}.

November 10, 2020
3:06 pm
Avatar
Member
Members
Forum Posts: 4
Member Since:
October 23, 2020
sp_userofflinesmall Offline

Thanks a lot!
How fast!
Now it is working properly; what a great job you do.

Forum Timezone: Europe/Moscow

Most Users Ever Online: 105

Currently Online:
10 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

ninja321: 81

Freedom: 61

B8europe: 54

saviulisse67: 45

adultdenim: 44

allgoodies: 38

Member Stats:

Guest Posters: 353

Members: 1944

Moderators: 0

Admins: 1

Forum Stats:

Groups: 1

Forums: 2

Topics: 1342

Posts: 6704

Administrators: CyberSEO: 3134