May 4, 2011

Internal WordPress error. Could not insert post into the database. | CyberSEO Pro | Support Forum

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
Internal WordPress error. Could not insert post into the database.
Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 (0 votes) 
March 24, 2024
10:53 am
Avatar
harboot
Member
Members
Forum Posts: 33
Member Since:
March 3, 2024
sp_UserOfflineSmall Offline

Syndicating RussianPanda Research…
Internal WordPress error. Could not insert post into the database.

Internal WordPress error. Could not insert post into the database.
2 posts were added

 

Syndicator Log

[24-03-24 09:40:01] Inserting a new post into the WordPress database
[24-03-24 09:40:02] Dalay for 1 second(s)
[24-03-24 09:40:03] Internal WordPress error. Could not insert post into the database.

 

Error only with this link :

Login to see this link
Login to see this link

 

Because the post is too long ???

March 24, 2024
10:57 am
Avatar
CyberSEO
Admin
Forum Posts: 3712
Member Since:
July 2, 2009
sp_UserOfflineSmall Offline

In this case, you need to check your feed settings, because the generated post cannot be added to the database – something is wrong with its content. I’ve just imported your URL and see this:

Login to see the quote

So it’s definitely not a bug in the code, because otherwise I would have the same result as you. We are using the same plugin, but our settings can be (and I’m sure they are) different.

March 25, 2024
3:14 am
Avatar
harboot
Member
Members
Forum Posts: 33
Member Since:
March 3, 2024
sp_UserOfflineSmall Offline

Thank you cyberseo,

I have tried to :

  1. Limited the %content% max 500 words
  2. Using %excerpt% for content
  3. Remove feed and create a new one

And its still same error. The weird is, its working fine with other russianpanda URL :D

 

Rightnow, Iam checking my server or DB configuration.

March 25, 2024
10:44 am
Avatar
CyberSEO
Admin
Forum Posts: 3712
Member Since:
July 2, 2009
sp_UserOfflineSmall Offline

You can export your feed to a file and email it to me so I can try to reproduce your situation locally.

March 25, 2024
11:59 am
Avatar
harboot
Member
Members
Forum Posts: 33
Member Since:
March 3, 2024
sp_UserOfflineSmall Offline

Email Sent

March 25, 2024
1:44 pm
Avatar
CyberSEO
Admin
Forum Posts: 3712
Member Since:
July 2, 2009
sp_UserOfflineSmall Offline

I didn’t see any problems with your feed settings, and I couldn’t reproduce your error message – the post was added successfully. Since you have the same plugin version and feed settings, the problem can only be with your server configuration.

This can be a problem with character encoding, various size limitations (e.g. upload_max_filesize, post_max_size in php.ini) etc.

For example, have you tried to turn off the full text extraction setting?

I would also recommend you to enable WordPress debug mode and then check server and PHP error logs (/var/log/php-error.log).

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 541

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

ninja321: 84

s.baryshev.aoasp: 64

Freedom: 61

MediFormatica: 49

B8europe: 47

saviulisse67: 45

Member Stats:

Guest Posters: 338

Members: 2672

Moderators: 0

Admins: 1

Forum Stats:

Groups: 1

Forums: 5

Topics: 1549

Posts: 7834

Newest Members:

dave.g6webservices, esl3.sphere79, dave.glaceau, acite1071, rosadoro, mark.frontiercreative

Administrators: CyberSEO: 3712